ZFX
ZFX Neu
Home
Community
Neueste Posts
Chat
FAQ
IOTW
Tutorials
Bücher
zfxCON
ZFXCE
Mathlib
ASSIMP
NES
Wir über uns
Impressum
Regeln
Suchen
Mitgliederliste
Membername:
Passwort:
Besucher:
4395393
Jetzt (Chat):
7 (0)
Mitglieder:
5239
Themen:
24223
Nachrichten:
234554
Neuestes Mitglied:
-insane-

ZFX
Sonstige Foren
Off-Topic
Re: Kdevelop IDE problem
Normal
AutorThema
exploid Bin Kaffee holen
ZFX'ler


Registriert seit:
21.08.2005

Deutschland
Kdevelop IDE problemNach oben.
Hallo

Hab ein Problem mit der Entwicklungsumgebung. Verwende sie mit Ubuntu und wollte "einfach mal" ein Projekt erstellen mit der Menüfunktion:
New Project -> C++ -> KDE -> Simple KDE Application

Das scheiterte mit 4 Fehlermeldungen dieser Natur:
acinclude.m4:3724: the serial number must appear before any macro definition

Hat jemand das Wissen diese Fehlermeldung zu verstehen?

Falls jemand bereit wär Licht in meine Unwissenheit zu bringen wäre ich dankbar dafür.

mfg
17.01.2009, 13:49:43 Uhr
Lynxeye Offline
ZFX'ler


Registriert seit:
30.11.2002

Sachsen
Re: Kdevelop IDE problemNach oben.
Ich weiß nicht woran das liegt. Allerdings ist Ubuntu GNOME und KDevolop eigtl eine KDE Anwendung. Keine Ahnung, ob es dabei Probleme geben kann.

KDevelop hat mich damals aber überhaupt nicht überzeugt, als ich es ausprobiert habe. Ich verwende mittlerer Weile Code::Blocks, von dem es auch Pakete für Ubuntu gibt. Vll ist das ja auch für dich mal einen Blick wert....

1 Mal gendert, zuletzt am 17.01.2009, 22:08:53 Uhr von Lynxeye.
17.01.2009, 22:08:43 Uhr
exploid Bin Kaffee holen
ZFX'ler


Registriert seit:
21.08.2005

Deutschland
Re: Kdevelop IDE problemNach oben.
hallo

werds mal anschauen danke für den Tipp

soweit ich herausgefunden von diversen blogs bezieht sich die Fehlermeldung wie sie ja auch beschreibt auf Definitionen von Macros und jemand sagte man sollte entsprechenden Teil einfach for allen Macros aus der entsprechenden make Datei setzen.

Die Lösung find ich aber mysteriös weil ja ensprechende Sequenz nicht ohne Grund an der Stelle steht wo es eingbaut wurde.
17.01.2009, 23:03:47 Uhr
Darkforce Offline
ZFX'ler


Registriert seit:
20.05.2003

Nordrhein-Westfalen
Re: Kdevelop IDE problemNach oben.
Hi,

leider werd ich im Augenblick aus den Googleergebnissen auch nicht ganz schlau.
Aber ich muss Lynxeye in sofern recht geben, als dass auch ich mit Kdevelop nicht besonders warm geworden bin (jetzt bin ich wieder bei vim, gdb/ddd und scons gelandet ).
Zusätzlich finde ich die Autotools generell nicht besonders entwicklerfreundlich. Da bieten sich "modernere" Buildsysteme wie CMake und Scons schon eher an.

Hilft dir jetzt bei deinem ursprünglichen Problem nicht direkt weiter, aber vielleicht versuchst du es ja mal mit einem anderen Buildsystem (keine Ahnung in wie weit diese von Kdevelop unterstützt werden).

Viele Grüße,
Darkforce
19.01.2009, 22:32:01 Uhr
Normal


ZFX Community Software, Version 0.9.1
Copyright 2002-2003 by Steffen Engel